<!doctype html >

<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->

<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->

<!--[if gt IE 8]><!--> <html lang="en-US" prefix="og: http://ogp.me/ns#"> <!--<![endif]-->

<head>

    

    <meta charset="UTF-8" />

    <meta name="viewport" content="width=device-width, initial-scale=1.0">

    <link rel="pingback" href="http://www.makaihawaii.com/xmlrpc.php" />

    <meta name='robots' content='max-image-preview:large' />
<link rel="icon" type="image/png" href="http://www.makaihawaii.com/wp-content/uploads/2018/06/makai_fav_ico2.png">
<!-- This site is optimized with the Yoast SEO Premium plugin v8.4 - https://yoast.com/wordpress/plugins/seo/ -->
<title>John John Florence Wins Haleiwa Challenger | Makai Hawaii</title>
<link rel="canonical" href="http://www.makaihawaii.com/uncategorized/john-john-florence-wins-haleiwa-challenger/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="John John Florence Wins Haleiwa Challenger | Makai Hawaii" />
<meta property="og:description" content="HALEIWA, Oahu/Hawaii (Sunday, December 5, 2021)&nbsp;&#8211;&nbsp;John John Florence&nbsp;(HAW) claimed victory at the World Surf League (WSL)&nbsp;Michelob ULTRA Pure Gold Haleiwa Challenger, the final stop of the 2021 Challenger Series, after overpowering XL swell at the iconic North Shore reef break along with&nbsp;Jack Robinson&nbsp;(AUS),&nbsp;Kanoa Igarashi&nbsp;(JPN), and&nbsp;Samuel Pupo&nbsp;(BRA) in a thrilling, action-packed Final. It was Florence’s ninth &hellip;" />
<meta property="og:url" content="http://www.makaihawaii.com/uncategorized/john-john-florence-wins-haleiwa-challenger/" />
<meta property="og:site_name" content="Makai Hawaii" />
<meta property="article:publisher" content="https://www.facebook.com/makaimagazine" />
<meta property="article:author" content="makaihawaii" />
<meta property="article:section" content="Uncategorized" />
<meta property="article:published_time" content="2021-12-08T00:56:00+00:00" />
<meta property="article:modified_time" content="2021-12-09T19:04:45+00:00" />
<meta property="og:updated_time" content="2021-12-09T19:04:45+00:00" />
<meta property="fb:app_id" content="215064055884966" />
<meta property="og:image" content="http://www.makaihawaii.com/wp-content/uploads/2021/12/John-John-Florence_21Haleiwa_B21I0047-1024x683.jpg" />
<meta property="og:image:width" content="1024" />
<meta property="og:image:height" content="683" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="HALEIWA, Oahu/Hawaii (Sunday, December 5, 2021)&nbsp;&#8211;&nbsp;John John Florence&nbsp;(HAW) claimed victory at the World Surf League (WSL)&nbsp;Michelob ULTRA Pure Gold Haleiwa Challenger, the final stop of the 2021 Challenger Series, after overpowering XL swell at the iconic North Shore reef break along with&nbsp;Jack Robinson&nbsp;(AUS),&nbsp;Kanoa Igarashi&nbsp;(JPN), and&nbsp;Samuel Pupo&nbsp;(BRA) in a thrilling, action-packed Final. It was Florence’s ninth [&hellip;]" />
<meta name="twitter:title" content="John John Florence Wins Haleiwa Challenger | Makai Hawaii" />
<meta name="twitter:site" content="@makaihawaii" />
<meta name="twitter:image" content="http://www.makaihawaii.com/wp-content/uploads/2021/12/John-John-Florence_21Haleiwa_B21I0047-1024x683.jpg" />
<meta name="twitter:creator" content="@makaihawaii" />
<script type='application/ld+json'>{"@context":"https:\/\/schema.org","@type":"Organization","url":"http:\/\/www.makaihawaii.com\/","sameAs":["https:\/\/www.facebook.com\/makaimagazine","https:\/\/www.instagram.com\/makaihawaii\/","https:\/\/twitter.com\/makaihawaii"],"@id":"http:\/\/www.makaihawaii.com\/#organization","name":"Makai Hawaii","logo":"http:\/\/www.makaihawaii.com\/wp-content\/uploads\/2021\/10\/makailogo-Converted-copy-copy-2-copy.pdf"}</script>
<!-- / Yoast SEO Premium plugin. -->

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Makai Hawaii &raquo; Feed" href="http://www.makaihawaii.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Makai Hawaii &raquo; Comments Feed" href="http://www.makaihawaii.com/comments/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.makaihawaii.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.8.2"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='http://www.makaihawaii.com/wp-includes/css/dist/block-library/style.min.css?ver=5.8.2' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-style-css' href="https://fonts.googleapis.com/css?family=Work+Sans%3A400%2C600%7COpen+Sans%3A300italic%2C400%2C400italic%2C600%2C600italic%2C700%7CRoboto%3A300%2C400%2C400italic%2C500%2C500italic%2C700%2C900%2C600&#038;ver=8.7.1" type='text/css' media='all' />
<link rel='stylesheet' id='tablepress-default-css'  href='http://www.makaihawaii.com/wp-content/plugins/tablepress/css/default.min.css?ver=1.14' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css'  href='http://www.makaihawaii.com/wp-content/themes/Newspaper/style.css?ver=8.7.1' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-demo-style-css'  href='http://www.makaihawaii.com/wp-content/themes/Newspaper/includes/demos/lifestyle/demo_style.css?ver=8.7.1' type='text/css' media='all' />
<script type='text/javascript' src='http://www.makaihawaii.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='http://www.makaihawaii.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<link rel="https://api.w.org/" href="http://www.makaihawaii.com/wp-json/" /><link rel="alternate" type="application/json" href="http://www.makaihawaii.com/wp-json/wp/v2/posts/1674" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.makaihawaii.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.makaihawaii.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.8.2" />
<link rel='shortlink' href='http://www.makaihawaii.com/?p=1674' />
<link rel="alternate" type="application/json+oembed" href="http://www.makaihawaii.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.makaihawaii.com%2Funcategorized%2Fjohn-john-florence-wins-haleiwa-challenger%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://www.makaihawaii.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.makaihawaii.com%2Funcategorized%2Fjohn-john-florence-wins-haleiwa-challenger%2F&#038;format=xml" />
			<script>
				window.tdwGlobal = {"adminUrl":"http:\/\/www.makaihawaii.com\/wp-admin\/","wpRestNonce":"668c3cebe3","wpRestUrl":"http:\/\/www.makaihawaii.com\/wp-json\/","permalinkStructure":"\/%category%\/%postname%\/"};
			</script>
			<!--[if lt IE 9]><script src="http://html5shim.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
    <!-- <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
  (adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-8556011785654950",
    enable_page_level_ads: true
  });
</script> -->
<script>
var pubg = pubg || {};
pubg.queue = pubg.queue || [];

headerBidderScript = document.createElement('script');
headerBidderScript.async = 'async';
headerBidderScript.src = "//delivery.pubgenius.io/www.maka-edacl3lK.js";
document.head.appendChild(headerBidderScript);
</script>
<!-- JS generated by theme -->

<script>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</script>


<!-- Header style compiled by theme -->

<style>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</style>

<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-110563316-2"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-110563316-2');
</script><script type="application/ld+json">
                        {
                            "@context": "http://schema.org",
                            "@type": "BreadcrumbList",
                            "itemListElement": [{
                            "@type": "ListItem",
                            "position": 1,
                                "item": {
                                "@type": "WebSite",
                                "@id": "http://www.makaihawaii.com/",
                                "name": "Home"                                               
                            }
                        },{
                            "@type": "ListItem",
                            "position": 2,
                                "item": {
                                "@type": "WebPage",
                                "@id": "http://www.makaihawaii.com/uncategorized/",
                                "name": "Uncategorized"
                            }
                        },{
                            "@type": "ListItem",
                            "position": 3,
                                "item": {
                                "@type": "WebPage",
                                "@id": "http://www.makaihawaii.com/uncategorized/john-john-florence-wins-haleiwa-challenger/",
                                "name": "John John Florence Wins Haleiwa Challenger"                                
                            }
                        }    ]
                        }
                       </script>	<style id="tdw-css-placeholder">.td-a-rec-id-sidebar > div {
  margin-bottom: 10px;
}
</style>	
	<!-- <script>
	var width = window.innerWidth
	|| document.documentElement.clientWidth
	|| document.body.clientWidth;

	if ( width > 600) {
		document.write('<script type="text/javascript" src="//delivery.mediadojo.co/7ZzX/jita.js?dfp=1" async defer><\/script>');
	}
	else {
		document.write('<script type="text/javascript" src="//delivery.mediadojo.co/lEYu/jita.js?dfp=1" async defer><\/script>');
	}
</script> -->

</head>



<body class="post-template-default single single-post postid-1674 single-format-standard john-john-florence-wins-haleiwa-challenger global-block-template-8 td-lifestyle single_template td-animation-stack-type0 td-full-layout" itemscope="itemscope" itemtype="http://schema.org/WebPage">




    
    <div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>

    

    <div class="td-menu-background"></div>
<div id="td-mobile-nav">
    <div class="td-mobile-container">
        <!-- mobile menu top section -->
        <div class="td-menu-socials-wrap">
            <!-- socials -->
            <div class="td-menu-socials">
                
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.facebook.com/makaihawaii" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.instagram.com/makaihawaii/" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://twitter.com/makaihawaii" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>            </div>
            <!-- close button -->
            <div class="td-mobile-close">
                <a href="#"><i class="td-icon-close-mobile"></i></a>
            </div>
        </div>

        <!-- login section -->
        
        <!-- menu section -->
        <div class="td-mobile-content">
            <div class="menu-mhmainmenu-container"><ul id="menu-mhmainmenu" class="td-mobile-main-menu"><li id="menu-item-149" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-first menu-item-149"><a href="http://www.makaihawaii.com/lifestyle/">Lifestyle<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-155" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-155"><a href="http://www.makaihawaii.com/lifestyle/surfing/">Surfing</a></li>
	<li id="menu-item-153" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-153"><a href="http://www.makaihawaii.com/lifestyle/health/">Health</a></li>
	<li id="menu-item-499" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-499"><a href="http://www.makaihawaii.com/lifestyle/waterman/">Waterman</a></li>
	<li id="menu-item-480" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-480"><a href="http://www.makaihawaii.com/lifestyle/canoe-paddling/">Canoe Paddling</a></li>
	<li id="menu-item-154" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-154"><a href="http://www.makaihawaii.com/lifestyle/paddle-boarding/">Paddle Boarding</a></li>
	<li id="menu-item-481" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-481"><a href="http://www.makaihawaii.com/lifestyle/canoe-sailing/">Canoe Sailing</a></li>
</ul>
</li>
<li id="menu-item-717" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-717"><a href="http://www.makaihawaii.com/makai-highlights/">Makai Highlights<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-719" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-719"><a href="http://www.makaihawaii.com/makai-highlights/island-native/">Island Native</a></li>
	<li id="menu-item-718" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-718"><a href="http://www.makaihawaii.com/makai-highlights/defining-priorities/">Defining Priorities</a></li>
	<li id="menu-item-720" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-720"><a href="http://www.makaihawaii.com/makai-highlights/home-grown/">Home Grown</a></li>
</ul>
</li>
<li id="menu-item-158" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-158"><a href="http://www.makaihawaii.com/reviews/">Reviews<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-702" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-702"><a href="http://www.makaihawaii.com/reviews/restaurant-reviews/">Restaurant Reviews</a></li>
</ul>
</li>
<li id="menu-item-156" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-156"><a href="http://www.makaihawaii.com/news/">News</a></li>
<li id="menu-item-493" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-493"><a href="http://www.makaihawaii.com/issues/">Magazine Issues</a></li>
</ul></div>        </div>
    </div>

    <!-- register/login section -->
    </div>
    <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
	<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
		<form method="get" class="td-search-form" action="http://www.makaihawaii.com/">
			<!-- close button -->
			<div class="td-search-close">
				<a href="#"><i class="td-icon-close-mobile"></i></a>
			</div>
			<div role="search" class="td-search-input">
				<span>Search</span>
				<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
			</div>
		</form>
		<div id="td-aj-search-mob"></div>
	</div>
</div>
    

    

    <div id="td-outer-wrap" class="td-theme-wrap">

    


        <!--
Header style 5
-->


<div class="td-header-wrap td-header-style-5 ">
    
    <div class="td-header-top-menu-full td-container-wrap ">
        <div class="td-container td-header-row td-header-top-menu">
            
    <div class="top-bar-style-1">
        
<div class="td-header-sp-top-menu">


	        <div class="td_data_time">
            <div >

                Sunday, December 12, 2021
            </div>
        </div>
    </div>
        <div class="td-header-sp-top-widget">
    
    
        
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.facebook.com/makaihawaii" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.instagram.com/makaihawaii/" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://twitter.com/makaihawaii" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>    </div>    </div>

<!-- LOGIN MODAL -->
        </div>
    </div>

    <div class="td-header-menu-wrap-full td-container-wrap ">
        
        <div class="td-header-menu-wrap ">
            <div class="td-container td-header-row td-header-main-menu black-menu">
                <div id="td-header-menu" role="navigation">
    <div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
    <div class="td-main-menu-logo td-logo-in-menu">
        		<a class="td-mobile-logo td-sticky-disable" href="http://www.makaihawaii.com/">
			<img class="td-retina-data" data-retina="http://makaihawaii.com/wp-content/uploads/2018/06/makailogo_mobile_retna.png" src="http://makaihawaii.com/wp-content/uploads/2018/06/makaimobilelogo.png" alt=""/>
		</a>
			<a class="td-header-logo td-sticky-disable" href="http://www.makaihawaii.com/">
			<img class="td-retina-data" data-retina="http://www.makaihawaii.com/wp-content/uploads/2018/06/makailogo_retna2-300x99.png" src="http://www.makaihawaii.com/wp-content/uploads/2018/06/makailogo_highres.png" alt=""/>
			<span class="td-visual-hidden">Makai Hawaii</span>
		</a>
	    </div>
    <div class="menu-mhmainmenu-container"><ul id="menu-mhmainmenu-1" class="sf-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-first td-menu-item td-normal-menu menu-item-149"><a href="http://www.makaihawaii.com/lifestyle/">Lifestyle</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-155"><a href="http://www.makaihawaii.com/lifestyle/surfing/">Surfing</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-153"><a href="http://www.makaihawaii.com/lifestyle/health/">Health</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-499"><a href="http://www.makaihawaii.com/lifestyle/waterman/">Waterman</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-480"><a href="http://www.makaihawaii.com/lifestyle/canoe-paddling/">Canoe Paddling</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-154"><a href="http://www.makaihawaii.com/lifestyle/paddle-boarding/">Paddle Boarding</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-481"><a href="http://www.makaihawaii.com/lifestyle/canoe-sailing/">Canoe Sailing</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-717"><a href="http://www.makaihawaii.com/makai-highlights/">Makai Highlights</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-719"><a href="http://www.makaihawaii.com/makai-highlights/island-native/">Island Native</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-718"><a href="http://www.makaihawaii.com/makai-highlights/defining-priorities/">Defining Priorities</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-720"><a href="http://www.makaihawaii.com/makai-highlights/home-grown/">Home Grown</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-158"><a href="http://www.makaihawaii.com/reviews/">Reviews</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-702"><a href="http://www.makaihawaii.com/reviews/restaurant-reviews/">Restaurant Reviews</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-156"><a href="http://www.makaihawaii.com/news/">News</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-493"><a href="http://www.makaihawaii.com/issues/">Magazine Issues</a></li>
</ul></div></div>


    <div class="header-search-wrap">
        <div class="td-search-btns-wrap">
            <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
            <a id="td-header-search-button-mob" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
        </div>

        <div class="td-drop-down-search" aria-labelledby="td-header-search-button">
            <form method="get" class="td-search-form" action="http://www.makaihawaii.com/">
                <div role="search" class="td-head-form-search-wrap">
                    <input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
                </div>
            </form>
            <div id="td-aj-search"></div>
        </div>
    </div>
            </div>
        </div>
    </div>

            <div class="td-header-header-full td-banner-wrap-full td-container-wrap ">
            <div class="td-container-header td-header-row td-header-header">
                <div class="td-header-sp-recs">
                    <div class="td-header-rec-wrap">
    <div class="td-a-rec td-a-rec-id-header  td_uid_1_61b59e8907558_rand td_block_template_8"><div class="td-all-devices" id='pubg-nzg-gtd'  style="overflow:hidden">
<script>
pubg.queue.push(function(){initAdUnit("pubg-nzg-gtd");});
</script>
</div>
<div class="td-all-devices" id='pubg-ij0-krt' style="overflow:hidden">
<script>pubg.queue.push(function(){initAdUnit("pubg-ij0-krt");});</script>
</div></div>
</div>                </div>
            </div>
        </div>
    
</div><div class="td-main-content-wrap td-container-wrap">

    <div class="td-container td-post-template-default ">
        <div class="td-crumb-container"><div class="entry-crumbs"><span><a title="" class="entry-crumb" href="http://www.makaihawaii.com/">Home</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in Uncategorized" class="entry-crumb" href="http://www.makaihawaii.com/uncategorized/">Uncategorized</a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last">John John Florence Wins Haleiwa Challenger</span></div></div>

        <div class="td-pb-row">
                                    <div class="td-pb-span8 td-main-content" role="main">
                            <div class="td-ss-main-content">
                                
    <article id="post-1674" class="post-1674 post type-post status-publish format-standard hentry category-uncategorized" itemscope itemtype="http://schema.org/Article">
        <div class="td-post-header">

            
            <header class="td-post-title">
                <h1 class="entry-title">John John Florence Wins Haleiwa Challenger</h1>

                

                <div class="td-module-meta-info">
                    <div class="td-post-author-name"><div class="td-author-by">By</div> <a href="http://www.makaihawaii.com/author/lono-goo/">#MakaiHawaii</a><div class="td-author-line"> - </div> </div>                    <span class="td-post-date td-post-date-no-dot"><time class="entry-date updated td-module-date" datetime="2021-12-08T00:56:00+00:00" >December 8, 2021</time></span>                                        <div class="td-post-views"><i class="td-icon-views"></i><span class="td-nr-views-1674">47</span></div>                </div>

            </header>

        </div>

        <div class="td-post-sharing-top"><div id="td_uid_2_61b59e89093d1" class="td-post-sharing td-ps-border td-ps-border-grey td-ps-rounded td-ps-padding td-ps-icon-color td-post-sharing-style18 "><div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-mail" href="/cdn-cgi/l/email-protection#58672b2d3a323d3b2c65123730367812373036781e34372a3d363b3d780f31362b781039343d312f39781b303934343d363f3d2a7e3a373c2165302c2c286277772f2f2f76353933393130392f393131763b3735772d363b392c3d3f372a31223d3c77323730367532373036753e34372a3d363b3d752f31362b753039343d312f39753b303934343d363f3d2a77">
                                        <div class="td-social-but-icon"><i class="td-icon-mail"></i></div>
                                        <div class="td-social-but-text">Email</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=http%3A%2F%2Fwww.makaihawaii.com%2Funcategorized%2Fjohn-john-florence-wins-haleiwa-challenger%2F">
                                        <div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
                                        <div class="td-social-but-text">Facebook</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=John+John+Florence+Wins+Haleiwa+Challenger&url=http%3A%2F%2Fwww.makaihawaii.com%2Funcategorized%2Fjohn-john-florence-wins-haleiwa-challenger%2F&via=makaihawaii">
                                        <div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
                                        <div class="td-social-but-text">Twitter</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-reddit" href="https://reddit.com/submit?url=http://www.makaihawaii.com/uncategorized/john-john-florence-wins-haleiwa-challenger/&title=John John Florence Wins Haleiwa Challenger">
                                        <div class="td-social-but-icon"><i class="td-icon-reddit"></i></div>
                                        <div class="td-social-but-text">ReddIt</div>
                                    </a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_uid_2_61b59e89093d1">
                                    <div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
                                </a></div></div></div>

        <div class="td-post-content">

        
        
<figure class="wp-block-table"><table><tbody><tr><td><strong>HALEIWA, Oahu/Hawaii (Sunday, December 5, 2021)</strong>&nbsp;&#8211;&nbsp;<strong>John John Florence</strong>&nbsp;(HAW) claimed victory at the World Surf League (WSL)<a href="https://worldsurfleague.us9.list-manage.com/track/click?u=9c75f4cf1e19118d57c2f963e&amp;id=5ad370d73b&amp;e=3ce49f164f">&nbsp;Michelob ULTRA Pure Gold Haleiwa Challenger</a>, the final stop of the 2021 Challenger Series, after overpowering XL swell at the iconic North Shore reef break along with&nbsp;<strong>Jack Robinson</strong>&nbsp;(AUS),&nbsp;<strong>Kanoa Igarashi&nbsp;</strong>(JPN), and&nbsp;<strong>Samuel Pupo</strong>&nbsp;(BRA) in a thrilling, action-packed Final. It was Florence’s ninth North Shore, Oahu victory in his career to tie the late, 3X WSL Champion&nbsp;<strong>Andy Irons</strong>&nbsp;(HAW). Also today, the women’s top seeds debuted in sensational form as their respective Quarterfinal draws are now locked in.&nbsp;</td></tr></tbody></table></figure>



<figure class="wp-block-table"><table><tbody><tr><td>“I’m feeling good, really good and it’s just so much fun being here and competing again,” said Florence. “After those injuries the last few years, it just feels good to be here and I just want to say thanks to my wife, my family, my whole team, and everyone who’s there supporting me. It’s been huge going through these last couple years and to be here winning again is awesome.”<br>&nbsp;<br>An early start from Pupo got the attention of eventual winner Florence as the North Shore, Oahu surfer unleashed an array of his signature power and progression on a wave at the midway point of the Final for a perfect 10 that had the crowd erupting in cheers and applause. The 29-year-old, 2X WSL Champion, wasn’t to be stopped &#8211; holding the highest single-wave score and heat total throughout the event &#8211; and placing&nbsp;all of the remaining finalists in a combination situation.</td></tr></tbody></table></figure>



<figure class="wp-block-gallery columns-1 is-cropped"><ul class="blocks-gallery-grid"><li class="blocks-gallery-item"><figure><img loading="lazy" width="1024" height="683" src="http://www.makaihawaii.com/wp-content/uploads/2021/12/John-John-Florence_21Haleiwa_B21I0047-1024x683.jpg" alt="" data-id="1675" data-full-url="http://www.makaihawaii.com/wp-content/uploads/2021/12/John-John-Florence_21Haleiwa_B21I0047.jpg" data-link="http://www.makaihawaii.com/?attachment_id=1675" class="wp-image-1675" srcset="http://www.makaihawaii.com/wp-content/uploads/2021/12/John-John-Florence_21Haleiwa_B21I0047-1024x683.jpg 1024w, http://www.makaihawaii.com/wp-content/uploads/2021/12/John-John-Florence_21Haleiwa_B21I0047-300x200.jpg 300w, http://www.makaihawaii.com/wp-content/uploads/2021/12/John-John-Florence_21Haleiwa_B21I0047-768x512.jpg 768w, http://www.makaihawaii.com/wp-content/uploads/2021/12/John-John-Florence_21Haleiwa_B21I0047-1536x1024.jpg 1536w, http://www.makaihawaii.com/wp-content/uploads/2021/12/John-John-Florence_21Haleiwa_B21I0047-2048x1365.jpg 2048w, http://www.makaihawaii.com/wp-content/uploads/2021/12/John-John-Florence_21Haleiwa_B21I0047-696x464.jpg 696w, http://www.makaihawaii.com/wp-content/uploads/2021/12/John-John-Florence_21Haleiwa_B21I0047-1068x712.jpg 1068w, http://www.makaihawaii.com/wp-content/uploads/2021/12/John-John-Florence_21Haleiwa_B21I0047-630x420.jpg 630w, http://www.makaihawaii.com/wp-content/uploads/2021/12/John-John-Florence_21Haleiwa_B21I0047-1920x1280.jpg 1920w" sizes="(max-width: 1024px) 100vw, 1024px" /><figcaption class="blocks-gallery-item__caption">HALEIWA, HAWAII &#8211; DECEMBER 5: Two-time WSL Champion John John Florence of Hawaii after winning the Final at the Michelob ULTRA Pure Gold Haleiwa Challenger on December 5, 2021 in Haleiwa, Hawaii. (Photo by Brent Bielmann/World Surf League)</figcaption></figure></li></ul></figure>



<figure class="wp-block-image size-large is-style-default"><img loading="lazy" width="1024" height="683" src="http://www.makaihawaii.com/wp-content/uploads/2021/12/John-John-Florence_21Haleiwa__TYH8603_Heff-1024x683.jpg" alt="" class="wp-image-1676" srcset="http://www.makaihawaii.com/wp-content/uploads/2021/12/John-John-Florence_21Haleiwa__TYH8603_Heff-1024x683.jpg 1024w, http://www.makaihawaii.com/wp-content/uploads/2021/12/John-John-Florence_21Haleiwa__TYH8603_Heff-300x200.jpg 300w, http://www.makaihawaii.com/wp-content/uploads/2021/12/John-John-Florence_21Haleiwa__TYH8603_Heff-768x512.jpg 768w, http://www.makaihawaii.com/wp-content/uploads/2021/12/John-John-Florence_21Haleiwa__TYH8603_Heff-1536x1024.jpg 1536w, http://www.makaihawaii.com/wp-content/uploads/2021/12/John-John-Florence_21Haleiwa__TYH8603_Heff-2048x1365.jpg 2048w, http://www.makaihawaii.com/wp-content/uploads/2021/12/John-John-Florence_21Haleiwa__TYH8603_Heff-696x464.jpg 696w, http://www.makaihawaii.com/wp-content/uploads/2021/12/John-John-Florence_21Haleiwa__TYH8603_Heff-1068x712.jpg 1068w, http://www.makaihawaii.com/wp-content/uploads/2021/12/John-John-Florence_21Haleiwa__TYH8603_Heff-630x420.jpg 630w, http://www.makaihawaii.com/wp-content/uploads/2021/12/John-John-Florence_21Haleiwa__TYH8603_Heff-1920x1280.jpg 1920w" sizes="(max-width: 1024px) 100vw, 1024px" /><figcaption>HALEIWA, HAWAII &#8211; DECEMBER 5: Two-time WSL Champion John John Florence of Hawaii surfing in the Final at the Michelob ULTRA Pure Gold Haleiwa Challenger on December 5, 2021 in Haleiwa, Hawaii. (Photo by Tony Heff/World Surf League)</figcaption></figure>



<p>For more information, please visit&nbsp;<a href="https://worldsurfleague.us9.list-manage.com/track/click?u=9c75f4cf1e19118d57c2f963e&amp;id=a137acbef5&amp;e=3ce49f164f" target="_blank" rel="noreferrer noopener">WorldSurfLeague.com</a>.&nbsp;</p>



<p><em>The Michelob ULTRA Pure Gold Haleiwa Challenger is proudly supported by Michelob ULTRA, Vans, Shiseido, Hydro Flask, Sambazon, Draft Kings, Expedia, and HIC.</em></p>
        </div>
<div id="disqus_thread"></div>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>

/**
*  RECOMMENDED CONFIGURATION VARIABLES: EDIT AND UNCOMMENT THE SECTION BELOW TO INSERT DYNAMIC VALUES FROM YOUR PLATFORM OR CMS.
*  LEARN WHY DEFINING THESE VARIABLES IS IMPORTANT: https://disqus.com/admin/universalcode/#configuration-variables*/
/*
var disqus_config = function () {
this.page.url = PAGE_URL;  // Replace PAGE_URL with your page's canonical URL variable
this.page.identifier = PAGE_IDENTIFIER; // Replace PAGE_IDENTIFIER with your page's unique identifier variable
};
*/
(function() { // DON'T EDIT BELOW THIS LINE
var d = document, s = d.createElement('script');
s.src = 'https://makaihawaii.disqus.com/embed.js';
s.setAttribute('data-timestamp', +new Date());
(d.head || d.body).appendChild(s);
})();
</script>
<noscript>Please enable JavaScript to view the <a href="https://disqus.com/?ref_noscript">comments powered by Disqus.</a></noscript>
  <div id="rcjsload_a122d7"></div>
<script src="//labs-cdn.revcontent.com/build/revmore-standard.min.js"></script>
<script type="text/javascript">
var devices = ['phone','tablet'];
var empty = revDetect.show(devices);
(function() {
var referer="";try{if(referer=document.referrer,"undefined"==typeof referer)throw"undefined"}catch(exception){referer=document.location.href,(""==referer||"undefined"==typeof referer)&&(referer=document.URL)}referer=referer.substr(0,700);
var rcel = document.createElement("script");
rcel.id = 'rc_' + Math.floor(Math.random() * 1000);
rcel.type = 'text/javascript';
rcel.src = "//trends.revcontent.com/serve.js.php?"+ (empty ? "empty=1&" : "") +"w=98920&t="+rcel.id+"&c="+(new Date()).getTime()+"&width="+(window.outerWidth || document.documentElement.clientWidth)+"&referer="+referer;
rcel.async = true;
var rcds = document.getElementById("rcjsload_a122d7"); rcds.appendChild(rcel);
var more = new RevMore({
    top_id: 'top-id',
    widget_id : 98920,
    devices: devices
});
})();
</script>                          

        <footer>
                        
            <div class="td-post-source-tags">
                                            </div>

                        <div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="http://www.makaihawaii.com/uncategorized/hawai%ca%bbi%ca%bb-honolua-blomfield-is-world-champion/">Hawaiʻiʻ Honolua Blomfield is World Champion</a></div></div><div class="td-next-prev-separator"></div></div>            <div class="td-author-name vcard author" style="display: none"><span class="fn"><a href="http://www.makaihawaii.com/author/lono-goo/">#MakaiHawaii</a></span></div>	        <span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="#MakaiHawaii"></span><meta itemprop="datePublished" content="2021-12-08T00:56:00+00:00"><meta itemprop="dateModified" content="2021-12-09T19:04:45+00:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="http://www.makaihawaii.com/uncategorized/john-john-florence-wins-haleiwa-challenger/"/><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://www.makaihawaii.com/wp-content/uploads/2018/06/makailogo_highres.png"></span><meta itemprop="name" content="Makai Hawaii"></span><meta itemprop="headline " content="John John Florence Wins Haleiwa Challenger"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://www.makaihawaii.com/wp-content/themes/Newspaper/images/no-thumb/td_meta_replacement.png"><meta itemprop="width" content="1068"><meta itemprop="height" content="580"></span>        </footer>

    </article> <!-- /.post -->

    <div class="td_block_wrap td_block_related_posts td_uid_4_61b59e890b5b5_rand td_with_ajax_pagination td-pb-border-top td_block_template_8"  data-td-block-uid="td_uid_4_61b59e890b5b5" ><script>var block_td_uid_4_61b59e890b5b5 = new tdBlock();
block_td_uid_4_61b59e890b5b5.id = "td_uid_4_61b59e890b5b5";
block_td_uid_4_61b59e890b5b5.atts = '{"limit":3,"ajax_pagination":"next_prev","live_filter":"cur_post_same_categories","td_ajax_filter_type":"td_custom_related","class":"td_uid_4_61b59e890b5b5_rand","td_column_number":3,"live_filter_cur_post_id":1674,"live_filter_cur_post_author":"15","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_ajax_preloading":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","tdc_css_class":"td_uid_4_61b59e890b5b5_rand","tdc_css_class_style":"td_uid_4_61b59e890b5b5_rand_style"}';
block_td_uid_4_61b59e890b5b5.td_column_number = "3";
block_td_uid_4_61b59e890b5b5.block_type = "td_block_related_posts";
block_td_uid_4_61b59e890b5b5.post_count = "3";
block_td_uid_4_61b59e890b5b5.found_posts = "50";
block_td_uid_4_61b59e890b5b5.header_color = "";
block_td_uid_4_61b59e890b5b5.ajax_pagination_infinite_stop = "";
block_td_uid_4_61b59e890b5b5.max_num_pages = "17";
tdBlocksArray.push(block_td_uid_4_61b59e890b5b5);
</script><h4 class="td-related-title td-block-title"><a id="td_uid_5_61b59e890ce70" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="td_uid_4_61b59e890b5b5" href="#">RELATED ARTICLES</a><a id="td_uid_6_61b59e890ceab" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="td_uid_4_61b59e890b5b5" href="#">MORE FROM AUTHOR</a></h4><div id=td_uid_4_61b59e890b5b5 class="td_block_inner">

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://www.makaihawaii.com/uncategorized/hawai%ca%bbi%ca%bb-honolua-blomfield-is-world-champion/" rel="bookmark" class="td-image-wrap" title="Hawaiʻiʻ Honolua Blomfield is World Champion"><img width="1" height="1" class="entry-thumb" src="http://www.makaihawaii.com/wp-content/uploads/2021/10/Bloomflied_H_21MalibuClassic_Lodin_07300-1.jpg" alt="" title="Hawaiʻiʻ Honolua Blomfield is World Champion"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://www.makaihawaii.com/uncategorized/hawai%ca%bbi%ca%bb-honolua-blomfield-is-world-champion/" rel="bookmark" title="Hawaiʻiʻ Honolua Blomfield is World Champion">Hawaiʻiʻ Honolua Blomfield is World Champion</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://www.makaihawaii.com/uncategorized/hawai%ca%bbi%ca%bbs-honolua-bloomfield-a-perfect-10/" rel="bookmark" class="td-image-wrap" title="Hawaiʻiʻs Honolua Bloomfield a Perfect 10"><img width="218" height="150" class="entry-thumb" src="http://www.makaihawaii.com/wp-content/themes/Newspaper/images/no-thumb/td_218x150.png" alt=""/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://www.makaihawaii.com/uncategorized/hawai%ca%bbi%ca%bbs-honolua-bloomfield-a-perfect-10/" rel="bookmark" title="Hawaiʻiʻs Honolua Bloomfield a Perfect 10">Hawaiʻiʻs Honolua Bloomfield a Perfect 10</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://www.makaihawaii.com/uncategorized/hui-wa%ca%bba-going-strong/" rel="bookmark" class="td-image-wrap" title="Hui Waʻa   Going Strong"><img width="218" height="150" class="entry-thumb" src="http://www.makaihawaii.com/wp-content/themes/Newspaper/images/no-thumb/td_218x150.png" alt=""/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://www.makaihawaii.com/uncategorized/hui-wa%ca%bba-going-strong/" rel="bookmark" title="Hui Waʻa   Going Strong">Hui Waʻa   Going Strong</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid--></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_4_61b59e890b5b5" data-td_block_id="td_uid_4_61b59e890b5b5"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_4_61b59e890b5b5" data-td_block_id="td_uid_4_61b59e890b5b5"><i class="td-icon-font td-icon-menu-right"></i></a></div></div> <!-- ./block -->
                            </div>
                        </div>
                        <div class="td-pb-span4 td-main-sidebar" role="complementary">
                            <div class="td-ss-main-sidebar">
                                <div class="td-a-rec td-a-rec-id-sidebar  td_uid_7_61b59e890e442_rand td_block_template_8"><div class="td-all-devices" id='pubg-smr-zy3' style="overflow:hidden">
<script>pubg.queue.push(function(){initAdUnit("pubg-smr-zy3");});</script>
</div>
<div class="td-all-devices" id='pubg-8gv-x7y' style="overflow:hidden">
<script>pubg.queue.push(function(){initAdUnit("pubg-8gv-x7y");});</script>
</div></div><div class="td_block_wrap td_block_9 td_block_widget td_uid_8_61b59e890e95e_rand td-pb-border-top td_block_template_8 td-column-1 td_block_padding td_block_bot_line"  data-td-block-uid="td_uid_8_61b59e890e95e" ><script>var block_td_uid_8_61b59e890e95e = new tdBlock();
block_td_uid_8_61b59e890e95e.id = "td_uid_8_61b59e890e95e";
block_td_uid_8_61b59e890e95e.atts = '{"sort":"random_posts","custom_title":"Recent Posts","limit":"5","header_color":"","class":"td_block_widget td_uid_8_61b59e890e95e_rand","separator":"","custom_url":"","block_template_id":"","m8_tl":"","post_ids":"","category_id":"","category_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","offset":"","el_class":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","td_ajax_preloading":"","f_header_font_header":"","f_header_font_title":"Block header","f_header_font_reset":"","f_header_font_family":"","f_header_font_size":"","f_header_font_line_height":"","f_header_font_style":"","f_header_font_weight":"","f_header_font_transform":"","f_header_font_spacing":"","f_header_":"","f_ajax_font_title":"Ajax categories","f_ajax_font_reset":"","f_ajax_font_family":"","f_ajax_font_size":"","f_ajax_font_line_height":"","f_ajax_font_style":"","f_ajax_font_weight":"","f_ajax_font_transform":"","f_ajax_font_spacing":"","f_ajax_":"","f_more_font_title":"Load more button","f_more_font_reset":"","f_more_font_family":"","f_more_font_size":"","f_more_font_line_height":"","f_more_font_style":"","f_more_font_weight":"","f_more_font_transform":"","f_more_font_spacing":"","f_more_":"","m8f_title_font_header":"","m8f_title_font_title":"Article title","m8f_title_font_reset":"","m8f_title_font_family":"","m8f_title_font_size":"","m8f_title_font_line_height":"","m8f_title_font_style":"","m8f_title_font_weight":"","m8f_title_font_transform":"","m8f_title_font_spacing":"","m8f_title_":"","m8f_cat_font_title":"Article category tag","m8f_cat_font_reset":"","m8f_cat_font_family":"","m8f_cat_font_size":"","m8f_cat_font_line_height":"","m8f_cat_font_style":"","m8f_cat_font_weight":"","m8f_cat_font_transform":"","m8f_cat_font_spacing":"","m8f_cat_":"","m8f_meta_font_title":"Article meta info","m8f_meta_font_reset":"","m8f_meta_font_family":"","m8f_meta_font_size":"","m8f_meta_font_line_height":"","m8f_meta_font_style":"","m8f_meta_font_weight":"","m8f_meta_font_transform":"","m8f_meta_font_spacing":"","m8f_meta_":"","ajax_pagination":"","ajax_pagination_infinite_stop":"","css":"","tdc_css":"","td_column_number":1,"color_preset":"","border_top":"","tdc_css_class":"td_uid_8_61b59e890e95e_rand","tdc_css_class_style":"td_uid_8_61b59e890e95e_rand_style"}';
block_td_uid_8_61b59e890e95e.td_column_number = "1";
block_td_uid_8_61b59e890e95e.block_type = "td_block_9";
block_td_uid_8_61b59e890e95e.post_count = "5";
block_td_uid_8_61b59e890e95e.found_posts = "120";
block_td_uid_8_61b59e890e95e.header_color = "";
block_td_uid_8_61b59e890e95e.ajax_pagination_infinite_stop = "";
block_td_uid_8_61b59e890e95e.max_num_pages = "24";
tdBlocksArray.push(block_td_uid_8_61b59e890e95e);
</script><div class="td-block-title-wrap"><h4 class="td-block-title"><span>Recent Posts</span></h4></div><div id=td_uid_8_61b59e890e95e class="td_block_inner">

	<div class="td-block-span12">

        <div class="td_module_8 td_module_wrap">

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://www.makaihawaii.com/lifestyle/surfing/guess-who-might-be-going-to-tahiti/" rel="bookmark" title="Guess Who Might Be Going To Tahiti?">Guess Who Might Be Going To Tahiti?</a></h3>
                <div class="td-module-meta-info">
                                        <span class="td-post-author-name"><a href="http://www.makaihawaii.com/author/gabbi-knutson/">Gabbi Knudson</a> <span>-</span> </span>                    <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2018-06-22T21:55:50+00:00" >June 22, 2018</time></span>                                    </div>
            </div>

            
        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_8 td_module_wrap">

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://www.makaihawaii.com/lifestyle/health/the-toxic-tuna-tradeoff/" rel="bookmark" title="The Toxic Tuna Tradeoff">The Toxic Tuna Tradeoff</a></h3>
                <div class="td-module-meta-info">
                                        <span class="td-post-author-name"><a href="http://www.makaihawaii.com/author/dr-landon-opunui/">Dr. Landon Opunui</a> <span>-</span> </span>                    <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2017-04-16T20:59:53+00:00" >April 16, 2017</time></span>                                    </div>
            </div>

            
        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_8 td_module_wrap">

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://www.makaihawaii.com/reviews/restaurant-reviews/new-island-eats-mike-and-billz-fire-grillz/" rel="bookmark" title="New Island Eats:  Mike and Billz Fire Grillz">New Island Eats:  Mike and Billz Fire Grillz</a></h3>
                <div class="td-module-meta-info">
                                        <span class="td-post-author-name"><a href="http://www.makaihawaii.com/author/lesleyanne-goo/">Lesleyanne Goo</a> <span>-</span> </span>                    <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2018-11-30T07:13:25+00:00" >November 30, 2018</time></span>                                    </div>
            </div>

            
        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_8 td_module_wrap">

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://www.makaihawaii.com/lifestyle/surfing/the-31st-quiksilver-in-memory-of-eddie-aikau/" rel="bookmark" title="The 31st Quiksilver In Memory of Eddie Aikau">The 31st Quiksilver In Memory of Eddie Aikau</a></h3>
                <div class="td-module-meta-info">
                                        <span class="td-post-author-name"><a href="http://www.makaihawaii.com/author/makai-hawaii-staff/">Makai Hawaii Staff</a> <span>-</span> </span>                    <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2015-12-02T04:22:47+00:00" >December 2, 2015</time></span>                                    </div>
            </div>

            
        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_8 td_module_wrap">

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://www.makaihawaii.com/lifestyle/canoe-paddling/micronesia-cup-palau-2016/" rel="bookmark" title="Micronesia Cup Palau 2016">Micronesia Cup Palau 2016</a></h3>
                <div class="td-module-meta-info">
                                        <span class="td-post-author-name"><a href="http://www.makaihawaii.com/author/makai-hawaii-staff/">Makai Hawaii Staff</a> <span>-</span> </span>                    <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2016-12-14T22:03:03+00:00" >December 14, 2016</time></span>                                    </div>
            </div>

            
        </div>

        
	</div> <!-- ./td-block-span12 --></div></div> <!-- ./block --><div class="td-a-rec td-a-rec-id-custom_ad_1  td_uid_9_61b59e891429e_rand td_block_template_8"><div class="td-all-devices" id='pubg-r9t-vtb'>
<script>pubg.queue.push(function(){initAdUnit("pubg-r9t-vtb");});</script>
</div>
<div class="td-all-devices" id='pubg-fsp-ywc' style="overflow:hidden>
<script>pubg.queue.push(function(){initAdUnit("pubg-fsp-ywc");});</script>
</div></div><aside class="td_block_template_8 widget widget_media_image"><a href="https://www.route99hawaii.com/"><img width="230" height="1024" src="http://www.makaihawaii.com/wp-content/uploads/2019/05/PNG-Makai-copy-230x1024.jpg" class="image wp-image-1344  attachment-large size-large" alt="" loading="lazy" style="max-width: 100%; height: auto;" /></a></aside>                            </div>
                        </div>
                            </div> <!-- /.td-pb-row -->
    </div> <!-- /.td-container -->
</div> <!-- /.td-main-content-wrap -->

<!-- Instagram -->




	<!-- Footer -->
	<div class="td-footer-wrapper td-container-wrap td-footer-template-2 ">
    <div class="td-container">

	    <div class="td-pb-row">
		    <div class="td-pb-span12">
			    		    </div>
	    </div>

        <div class="td-pb-row">

            <div class="td-pb-span4">
                <div class="td-footer-info"><div class="footer-logo-wrap"><a href="http://www.makaihawaii.com/"><img class="td-retina-data" src="http://www.makaihawaii.com/wp-content/uploads/2018/08/makai_subfooter_logo_white-1.png" data-retina="http://www.makaihawaii.com/wp-content/uploads/2018/08/makai_subfooter_logo_white_retna.png" alt="Makai Hawaii Logo" title="Makai Hawaii Logo" width="265" /></a></div><div class="footer-text-wrap">Since 2004 Makai Ocean Lifestyle Magazine has become Hawai‘iʻs favorite souce featuring the Hawaii’s Ocean Lifestyle, with features of the Worlds Finest Water enthusiast .

Our monthly publication, reaches over 50,000 readers each month, and is read online by an additional 4000 readers worldwide.

If you would like to Contact us via email by this form, or directly at: <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="cba2a5ada48ba6aaa0aaa2a3aabcaaa2a2e5a8a4a6">[email&#160;protected]</a>

We hope you enjoy our publication and we welcome you to check our website each month for our great features.<div class="footer-email-wrap">Contact us: <a href="/cdn-cgi/l/email-protection#630a0d050c230e0208020a0b0214020a0a4d000c0e"><span class="__cf_email__" data-cfemail="e28b8c848da28f8389838b8a8395838b8bcc818d8f">[email&#160;protected]</span></a></div></div><div class="footer-social-wrap td-social-style-2">
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.facebook.com/makaihawaii" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.instagram.com/makaihawaii/" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://twitter.com/makaihawaii" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span></div></div>                            </div>

            <div class="td-pb-span4">
                <div class="td_block_wrap td_block_7 td_uid_11_61b59e89167d0_rand td-pb-border-top td_block_template_8 td-column-1 td_block_padding"  data-td-block-uid="td_uid_11_61b59e89167d0" ><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>var block_td_uid_11_61b59e89167d0 = new tdBlock();
block_td_uid_11_61b59e89167d0.id = "td_uid_11_61b59e89167d0";
block_td_uid_11_61b59e89167d0.atts = '{"custom_title":"POPULAR POSTS","limit":3,"sort":"popular","separator":"","custom_url":"","block_template_id":"","m6_tl":"","post_ids":"","category_id":"","category_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","offset":"","el_class":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","td_ajax_preloading":"","f_header_font_header":"","f_header_font_title":"Block header","f_header_font_reset":"","f_header_font_family":"","f_header_font_size":"","f_header_font_line_height":"","f_header_font_style":"","f_header_font_weight":"","f_header_font_transform":"","f_header_font_spacing":"","f_header_":"","f_ajax_font_title":"Ajax categories","f_ajax_font_reset":"","f_ajax_font_family":"","f_ajax_font_size":"","f_ajax_font_line_height":"","f_ajax_font_style":"","f_ajax_font_weight":"","f_ajax_font_transform":"","f_ajax_font_spacing":"","f_ajax_":"","f_more_font_title":"Load more button","f_more_font_reset":"","f_more_font_family":"","f_more_font_size":"","f_more_font_line_height":"","f_more_font_style":"","f_more_font_weight":"","f_more_font_transform":"","f_more_font_spacing":"","f_more_":"","m6f_title_font_header":"","m6f_title_font_title":"Article title","m6f_title_font_reset":"","m6f_title_font_family":"","m6f_title_font_size":"","m6f_title_font_line_height":"","m6f_title_font_style":"","m6f_title_font_weight":"","m6f_title_font_transform":"","m6f_title_font_spacing":"","m6f_title_":"","m6f_cat_font_title":"Article category tag","m6f_cat_font_reset":"","m6f_cat_font_family":"","m6f_cat_font_size":"","m6f_cat_font_line_height":"","m6f_cat_font_style":"","m6f_cat_font_weight":"","m6f_cat_font_transform":"","m6f_cat_font_spacing":"","m6f_cat_":"","m6f_meta_font_title":"Article meta info","m6f_meta_font_reset":"","m6f_meta_font_family":"","m6f_meta_font_size":"","m6f_meta_font_line_height":"","m6f_meta_font_style":"","m6f_meta_font_weight":"","m6f_meta_font_transform":"","m6f_meta_font_spacing":"","m6f_meta_":"","ajax_pagination":"","ajax_pagination_infinite_stop":"","css":"","tdc_css":"","td_column_number":1,"header_color":"","color_preset":"","border_top":"","class":"td_uid_11_61b59e89167d0_rand","tdc_css_class":"td_uid_11_61b59e89167d0_rand","tdc_css_class_style":"td_uid_11_61b59e89167d0_rand_style"}';
block_td_uid_11_61b59e89167d0.td_column_number = "1";
block_td_uid_11_61b59e89167d0.block_type = "td_block_7";
block_td_uid_11_61b59e89167d0.post_count = "3";
block_td_uid_11_61b59e89167d0.found_posts = "120";
block_td_uid_11_61b59e89167d0.header_color = "";
block_td_uid_11_61b59e89167d0.ajax_pagination_infinite_stop = "";
block_td_uid_11_61b59e89167d0.max_num_pages = "40";
tdBlocksArray.push(block_td_uid_11_61b59e89167d0);
</script><div class="td-block-title-wrap"><h4 class="td-block-title"><span>POPULAR POSTS</span></h4></div><div id=td_uid_11_61b59e89167d0 class="td_block_inner">

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="http://www.makaihawaii.com/uncategorized/buffalo-big-board-surfing-contest/" rel="bookmark" class="td-image-wrap" title="The 43rd Buffalo Big Board Surfing Classic 2019"><img width="100" height="70" class="entry-thumb" src="http://www.makaihawaii.com/wp-content/uploads/2019/01/BBBBSC2019-Poster-100x70.jpg" srcset="http://www.makaihawaii.com/wp-content/uploads/2019/01/BBBBSC2019-Poster-100x70.jpg 100w, http://www.makaihawaii.com/wp-content/uploads/2019/01/BBBBSC2019-Poster-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="" title="The 43rd Buffalo Big Board Surfing Classic 2019"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="http://www.makaihawaii.com/uncategorized/buffalo-big-board-surfing-contest/" rel="bookmark" title="The 43rd Buffalo Big Board Surfing Classic 2019">The 43rd Buffalo Big Board Surfing Classic 2019</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2019-01-31T07:14:05+00:00" >January 31, 2019</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="http://www.makaihawaii.com/lifestyle/canoe-sailing/canoe-sailing-just-try-to-keep-up-with-mike-kincaid/" rel="bookmark" class="td-image-wrap" title="Canoe Sailing: Just Try to Keep Up with Mike Kincaid"><img width="100" height="70" class="entry-thumb" src="http://www.makaihawaii.com/wp-content/uploads/2018/07/canoe-sailing-100x70.png" srcset="http://www.makaihawaii.com/wp-content/uploads/2018/07/canoe-sailing-100x70.png 100w, http://www.makaihawaii.com/wp-content/uploads/2018/07/canoe-sailing-218x150.png 218w" sizes="(max-width: 100px) 100vw, 100px" alt="canoe sailing" title="Canoe Sailing: Just Try to Keep Up with Mike Kincaid"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="http://www.makaihawaii.com/lifestyle/canoe-sailing/canoe-sailing-just-try-to-keep-up-with-mike-kincaid/" rel="bookmark" title="Canoe Sailing: Just Try to Keep Up with Mike Kincaid">Canoe Sailing: Just Try to Keep Up with Mike Kincaid</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2016-09-16T20:48:08+00:00" >September 16, 2016</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="http://www.makaihawaii.com/makai-highlights/island-native/3x-world-champion-carissa-moore/" rel="bookmark" class="td-image-wrap" title="Island Native : 3x World Surfing Champion Carissa Moore"><img width="100" height="70" class="entry-thumb" src="http://www.makaihawaii.com/wp-content/uploads/2016/09/carrisa-moore-100x70.png" srcset="http://www.makaihawaii.com/wp-content/uploads/2016/09/carrisa-moore-100x70.png 100w, http://www.makaihawaii.com/wp-content/uploads/2016/09/carrisa-moore-218x150.png 218w" sizes="(max-width: 100px) 100vw, 100px" alt="carrisa moore" title="Island Native : 3x World Surfing Champion Carissa Moore"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="http://www.makaihawaii.com/makai-highlights/island-native/3x-world-champion-carissa-moore/" rel="bookmark" title="Island Native : 3x World Surfing Champion Carissa Moore">Island Native : 3x World Surfing Champion Carissa Moore</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2016-09-16T19:46:22+00:00" >September 16, 2016</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 --></div></div> <!-- ./block -->                            </div>

            <div class="td-pb-span4">
                <div class="td_block_wrap td_block_popular_categories td_uid_12_61b59e891bbcf_rand widget widget_categories td-pb-border-top td_block_template_8"  data-td-block-uid="td_uid_12_61b59e891bbcf" ><div class="td-block-title-wrap"><h4 class="td-block-title"><span>POPULAR CATEGORY</span></h4></div><ul class="td-pb-padding-side"><li><a href="http://www.makaihawaii.com/lifestyle/surfing/"><span class="td-cat-name">Surfing</span><span class="td-cat-no">23</span></a></li><li><a href="http://www.makaihawaii.com/lifestyle/canoe-paddling/"><span class="td-cat-name">Canoe Paddling</span><span class="td-cat-no">21</span></a></li><li><a href="http://www.makaihawaii.com/culture/hawaiian/"><span class="td-cat-name">Hawaiian</span><span class="td-cat-no">14</span></a></li><li><a href="http://www.makaihawaii.com/makai-highlights/island-native/"><span class="td-cat-name">Island Native</span><span class="td-cat-no">14</span></a></li><li><a href="http://www.makaihawaii.com/lifestyle/health/"><span class="td-cat-name">Health</span><span class="td-cat-no">10</span></a></li><li><a href="http://www.makaihawaii.com/lifestyle/"><span class="td-cat-name">Lifestyle</span><span class="td-cat-no">8</span></a></li><li><a href="http://www.makaihawaii.com/culture/"><span class="td-cat-name">Culture</span><span class="td-cat-no">7</span></a></li><li><a href="http://www.makaihawaii.com/lifestyle/waterman/"><span class="td-cat-name">Waterman</span><span class="td-cat-no">7</span></a></li></ul></div> <!-- ./block -->                            </div>
        </div>
    </div>
</div>

	<!-- Sub Footer -->
	    <div class="td-sub-footer-container td-container-wrap ">
        <div class="td-container">
            <div class="td-pb-row">
                <div class="td-pb-span td-sub-footer-menu">
                                    </div>

                <div class="td-pb-span td-sub-footer-copy">
                    &copy; Copyright 2019 - Powered By pubGenius                </div>
            </div>
        </div>
    </div>


</div><!--close td-outer-wrap-->



    <!--

        Theme: Newspaper by tagDiv.com 2017
        Version: 8.7.1 (rara)
        Deploy mode: deploy
        
        uid: 61b59e891d4e0
    -->

    <script type='text/javascript' src='http://www.makaihawaii.com/wp-content/themes/Newspaper/js/tagdiv_theme.min.js?ver=8.7.1' id='td-site-min-js'></script>
<script type='text/javascript' src='http://www.makaihawaii.com/wp-includes/js/comment-reply.min.js?ver=5.8.2' id='comment-reply-js'></script>
<script type='text/javascript' src='http://www.makaihawaii.com/wp-includes/js/wp-embed.min.js?ver=5.8.2' id='wp-embed-js'></script>

<!-- JS generated by theme -->

<script>
    

	

		(function(){
			var html_jquery_obj = jQuery('html');

			if (html_jquery_obj.length && (html_jquery_obj.is('.ie8') || html_jquery_obj.is('.ie9'))) {

				var path = 'http://www.makaihawaii.com/wp-content/themes/Newspaper/style.css';

				jQuery.get(path, function(data) {

					var str_split_separator = '#td_css_split_separator';
					var arr_splits = data.split(str_split_separator);
					var arr_length = arr_splits.length;

					if (arr_length > 1) {

						var dir_path = 'http://www.makaihawaii.com/wp-content/themes/Newspaper';
						var splited_css = '';

						for (var i = 0; i < arr_length; i++) {
							if (i > 0) {
								arr_splits[i] = str_split_separator + ' ' + arr_splits[i];
							}
							//jQuery('head').append('<style>' + arr_splits[i] + '</style>');

							var formated_str = arr_splits[i].replace(/\surl\(\'(?!data\:)/gi, function regex_function(str) {
								return ' url(\'' + dir_path + '/' + str.replace(/url\(\'/gi, '').replace(/^\s+|\s+$/gm,'');
							});

							splited_css += "<style>" + formated_str + "</style>";
						}

						var td_theme_css = jQuery('link#td-theme-css');

						if (td_theme_css.length) {
							td_theme_css.after(splited_css);
						}
					}
				});
			}
		})();

	
	
</script>



			<div id="tdw-css-writer" style="display: none" class="tdw-drag-dialog tdc-window-sidebar">
				<header>

				
					<a title="Editor" class="tdw-tab tdc-tab-active" href="#" data-tab-content="tdw-tab-editor">Edit with Live CSS</a>
					<div class="tdw-less-info" title="This will be red when errors are detected in your CSS and LESS"></div>
				
				</header>
				<div class="tdw-content">

					
					<div class="tdw-tabs-content tdw-tab-editor tdc-tab-content-active">


						<script>

							(function(jQuery, undefined) {

								jQuery(window).ready(function() {

									if ( 'undefined' !== typeof tdcAdminIFrameUI ) {
										var $liveIframe  = tdcAdminIFrameUI.getLiveIframe();

										if ( $liveIframe.length ) {
											$liveIframe.load(function() {
												$liveIframe.contents().find( 'body').append( '<textarea class="tdw-css-writer-editor" style="display: none"></textarea>' );
											});
										}
									}

								});

							})(jQuery);

						</script>


						<textarea class="tdw-css-writer-editor td_live_css_uid_1_61b59e891d750">.td-a-rec-id-sidebar > div {
  margin-bottom: 10px;
}</textarea>
						<div id="td_live_css_uid_1_61b59e891d750" class="td-code-editor"></div>


						<script>
							jQuery(window).load(function (){

								if ( 'undefined' !== typeof tdLiveCssInject ) {

									tdLiveCssInject.init();


									var editor_textarea = jQuery('.td_live_css_uid_1_61b59e891d750');
									var languageTools = ace.require("ace/ext/language_tools");
									var tdcCompleter = {
										getCompletions: function (editor, session, pos, prefix, callback) {
											if (prefix.length === 0) {
												callback(null, []);
												return
											}

											if ('undefined' !== typeof tdcAdminIFrameUI) {

												var data = {
													error: undefined,
													getShortcode: ''
												};

												tdcIFrameData.getShortcodeFromData(data);

												if (!_.isUndefined(data.error)) {
													tdcDebug.log(data.error);
												}

												if (!_.isUndefined(data.getShortcode)) {

													var regex = /el_class=\"([A-Za-z0-9_-]*\s*)+\"/g,
														results = data.getShortcode.match(regex);

													var elClasses = {};

													for (var i = 0; i < results.length; i++) {
														var currentClasses = results[i]
															.replace('el_class="', '')
															.replace('"', '')
															.split(' ');

														for (var j = 0; j < currentClasses.length; j++) {
															if (_.isUndefined(elClasses[currentClasses[j]])) {
																elClasses[currentClasses[j]] = '';
															}
														}
													}

													var arrElClasses = [];

													for (var prop in elClasses) {
														arrElClasses.push(prop);
													}

													callback(null, arrElClasses.map(function (item) {
														return {
															name: item,
															value: item,
															meta: 'in_page'
														}
													}));
												}
											}
										}
									};
									languageTools.addCompleter(tdcCompleter);

									window.editor = ace.edit("td_live_css_uid_1_61b59e891d750");

									// 'change' handler is written as function because it's called by tdc_on_add_css_live_components (of wp_footer hook)
									// We did it to reattach the existing compiled css to the new content received from server.
									window.editorChangeHandler = function () {
										//tdwState.lessWasEdited = true;

										window.onbeforeunload = function () {
											if (tdwState.lessWasEdited) {
												return "You have attempted to leave this page. Are you sure?";
											}
											return false;
										};

										var editorValue = editor.getSession().getValue();

										editor_textarea.val(editorValue);

										if ('undefined' !== typeof tdcAdminIFrameUI) {
											tdcAdminIFrameUI.getLiveIframe().contents().find('.tdw-css-writer-editor:first').val(editorValue);

											// Mark the content as modified
											// This is important for showing info when composer closes
                                            tdcMain.setContentModified();
										}

										tdLiveCssInject.less();
									};

									editor.getSession().setValue(editor_textarea.val());
									editor.getSession().on('change', editorChangeHandler);

									editor.setTheme("ace/theme/textmate");
									editor.setShowPrintMargin(false);
									editor.getSession().setMode("ace/mode/less");
									editor.setOptions({
										enableBasicAutocompletion: true,
										enableSnippets: true,
										enableLiveAutocompletion: false
									});

								}

							});
						</script>

					</div>
				</div>

				<footer>

					
						<a href="#" class="tdw-save-css">Save</a>
						<div class="tdw-more-info-text">Write CSS OR LESS and hit save. CTRL + SPACE for auto-complete.</div>

					
					<div class="tdw-resize"></div>
				</footer>
			</div>
			<script id="dsq-count-scr" src="//makaihawaii.disqus.com/count.js" async></script>
</body>
</html>